Для этой версии Subscribe2 требуется WordPress 4.4 или выше. Обновите <a href="http://codex.wordpress.org/Updating_WordPress">WordPress</a> или используйте более старую версию <a href="https://subscribe2.wordpress.com/subscribe2-html/">Subscribe2</a>.